using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^.*\bEXCLUDE\b.*\K(?:\R(?!.*\bEXCLUDE\b).*)+";
string input = @"EXCLUDE this entire line
include this line
and this as single match
and EXCLUDE this line";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}