re = /^.*\bEXCLUDE\b.*\K(?:\R(?!.*\bEXCLUDE\b).*)+/m
str = 'EXCLUDE this entire line
include this line
and this as single match
and EXCLUDE this line'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end