using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"WHEN (?:(?! +(?:WHEN|ELSE)).)*";
string input = @"CASE WHEN ""Expressions"".""PRODUCT_CATEGORIES"".""CATEGORY_NAME""=\'CPU\' THEN \'YES\' WHEN ""Expressions"".""PRODUCT_CATEGORIES"".""CATEGORY_NAME""=\'RAM\' THEN \'YES\' ELSE \'NO\' END
CASE WHEN (""Expressions"".""ORDER_ITEMS"".""QUANTITY""*""Expressions"".""ORDER_ITEMS"".""UNIT_PRICE"")>0 THEN (""Expressions"".""ORDER_ITEMS"".""QUANTITY""* ""Expressions"".""ORDER_ITEMS"".""UNIT_PRICE"") ELSE (""Expressions"".""ORDER_ITEMS"".""QUANTITY""+ ""Expressions"".""ORDER_ITEMS"".""UNIT_PRICE"") END ";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}