re = /WHEN (?:(?! +(?:WHEN|ELSE)).)*/i
str = 'CASE WHEN "Expressions"."PRODUCT_CATEGORIES"."CATEGORY_NAME"=\\\'CPU\\\' THEN \\\'YES\\\' WHEN "Expressions"."PRODUCT_CATEGORIES"."CATEGORY_NAME"=\\\'RAM\\\' THEN \\\'YES\\\' ELSE \\\'NO\\\' END
CASE WHEN ("Expressions"."ORDER_ITEMS"."QUANTITY"*"Expressions"."ORDER_ITEMS"."UNIT_PRICE")>0 THEN ("Expressions"."ORDER_ITEMS"."QUANTITY"* "Expressions"."ORDER_ITEMS"."UNIT_PRICE") ELSE ("Expressions"."ORDER_ITEMS"."QUANTITY"+ "Expressions"."ORDER_ITEMS"."UNIT_PRICE") END '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end