package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\w+:\/\/([\w|\.]+)`)
var str = `https://regexrocks.com/my/socks/off
`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}