$re = '/\w+:\/\/([\w|\.]+)/';
$str = 'https://regexrocks.com/my/socks/off
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);