package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)(\d{1,2})(:\d{1,2})?(\s+)?-(\s+)?(\d{1,2})(:\d{1,2})?(am|pm)`)
var str = `bla bla 1:30-2pm bla bla 5-6:30am some text 1-2:15am
bla bla 1:30 - 2pm bla bla 5 - 6:30am some text 1 - 2:15am`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}