re = /(\d{1,2})(:\d{1,2})?(\s+)?-(\s+)?(\d{1,2})(:\d{1,2})?(am|pm)/mi
str = 'bla bla 1:30-2pm bla bla 5-6:30am some text 1-2:15am
bla bla 1:30 - 2pm bla bla 5 - 6:30am some text 1 - 2:15am'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end