package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(|by DocuSign)((|0)[1-9]|1[0-2])\/((|0)[1-9]|[1-2][0-9]|3[0-1])\/[0-9]{4}$`)
var str = `01/31/2021
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}