using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?=.*[A-Za-z])(?=.*\d)[A-Za-z0-9\-#.\/]+$";
string input = @"abc
123
abc123
abc123#
abc#
123#";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}