$re = '/^[\w\s.-]+$/im';
$str = 'some string
not&
eh um.
some----';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);