$re = '/^(?=b*a)(?:a*ba*ba*)+$/m';
$str = 'abb
abab
aaaa
baaab
aba
abababa
bbaabba
bb
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);