re = /^(?=b*a)(?:a*ba*ba*)+$/m
str = 'abb
abab
aaaa
baaab
aba
abababa
bbaabba
bb
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end