const regex = new RegExp('(?s)\\s*Hello.*?world', 'gm')
const str = `test 1
Hello
foo
bar
a better world
foo
bar
world
test 2`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);