import re
regex = re.compile(r"(?s)\s*Hello.*?world", flags=re.MULTILINE)
test_str = ("test 1\n"
"Hello\n"
"foo\n"
"bar\n"
"a better world\n"
"foo\n"
"bar\n"
"world\n"
"test 2")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)