package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[\u4e00-\u9fff\u3400-\u4dff\uf900-\ufaff\u30a0-\u30ff\u3040-\u309f]`)
var str = `dアdd達[になれた] 桃五[いつ]つ`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}