re = /[\u4e00-\u9fff\u3400-\u4dff\uf900-\ufaff\u30a0-\u30ff\u3040-\u309f]/m
str = 'dアdd達[になれた] 桃五[いつ]つ'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end