$re = '/^(\d+\.)?(\d+\.)?(\*|\d+)/';
$str = '0.6.12+commit.27d51765
solidity version';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);