re = /^(\d+\.)?(\d+\.)?(\*|\d+)/
str = '0.6.12+commit.27d51765
solidity version'
# Print the match result
str.match(re) do |match|
puts match.to_s
end