# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = (r"((http:\/\/(soundcloud\.com\/.*|soundcloud\.com\/.*\/.*|soundcloud\.com\/.*\/sets\/.*|soundcloud\.com\/groups\/.*|snd\.sc\/.*))|(https:\/\/(soundcloud\.com\/.*|soundcloud\.com\/.*\/.*|soundcloud\.com\/.*\/sets\/.*|soundcloud\.com\/groups\/.*)))\n")
test_str = ("Some useless text : Lorem ipsum dolor sit amet, consectetur adipiscing elit. Ex rebus enim timiditas, non ex vocabulis nascitur. At miser, si in flagitiosa et vitiosa vita afflueret voluptatibus. Sin dicit obscurari quaedam nec apparere, quia valde parva sint, nos quoque concedimus; Duo Reges: constructio interrete. Qui autem esse poteris, nisi te amor ipse ceperit? Cum ageremus, inquit, vitae beatum et eundem supremum diem, scribebamus haec. Teneo, inquit, finem illi videri nihil dolere. Memini vero, inquam; \n"
"https://soundcloud.com/hummus-records-1/sets/louis-jucker-some-of-the-missing-ones\n\n"
"https://soundcloud.com/hummus-records-1/01-nevborn-sending-a-message?in=hummus-records-1/sets/nevborn\n\n"
"Iubet igitur nos Pythius Apollo noscere nosmet ipsos. Aeque enim contingit omnibus fidibus, ut incontentae sint. An vero, inquit,\n"
"https://soundcloud.com/hummus-records-1/sets/schwarz-1 quisquam potest probare, quod perceptfum, quod. Sed ad illum redeo. Sapientem locupletat ipsa natura, cuius divitias Epicurus parabiles esse docuit. Tamen a proposito, inquam, aberramus. Sint modo partes vitae beatae. Duarum enim vitarum nobis erunt instituta capienda.\n"
"asd\n"
"http://snd.sc/yp6VMo \n\n"
"http://asd.ch \n"
"asdf")
matches = re.finditer(regex, test_str, re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.