import Foundation
let pattern = #"""
((http:\/\/(soundcloud\.com\/.*|soundcloud\.com\/.*\/.*|soundcloud\.com\/.*\/sets\/.*|soundcloud\.com\/groups\/.*|snd\.sc\/.*))|(https:\/\/(soundcloud\.com\/.*|soundcloud\.com\/.*\/.*|soundcloud\.com\/.*\/sets\/.*|soundcloud\.com\/groups\/.*)))
"""#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"""
Some useless text : Lorem ipsum dolor sit amet, consectetur adipiscing elit. Ex rebus enim timiditas, non ex vocabulis nascitur. At miser, si in flagitiosa et vitiosa vita afflueret voluptatibus. Sin dicit obscurari quaedam nec apparere, quia valde parva sint, nos quoque concedimus; Duo Reges: constructio interrete. Qui autem esse poteris, nisi te amor ipse ceperit? Cum ageremus, inquit, vitae beatum et eundem supremum diem, scribebamus haec. Teneo, inquit, finem illi videri nihil dolere. Memini vero, inquam;
https://soundcloud.com/hummus-records-1/sets/louis-jucker-some-of-the-missing-ones
https://soundcloud.com/hummus-records-1/01-nevborn-sending-a-message?in=hummus-records-1/sets/nevborn
Iubet igitur nos Pythius Apollo noscere nosmet ipsos. Aeque enim contingit omnibus fidibus, ut incontentae sint. An vero, inquit,
https://soundcloud.com/hummus-records-1/sets/schwarz-1 quisquam potest probare, quod perceptfum, quod. Sed ad illum redeo. Sapientem locupletat ipsa natura, cuius divitias Epicurus parabiles esse docuit. Tamen a proposito, inquam, aberramus. Sint modo partes vitae beatae. Duarum enim vitarum nobis erunt instituta capienda.
asd
http://snd.sc/yp6VMo
http://asd.ch
asdf
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)