using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[^a\n\r]*(?<!\S)([^\Wa]*a\w*)(?!\S)";
string input = @"The cat ate the dog
and the mouse
this is a test
a
when will this be matching?
@!#SSDF2#$@a#$dsfs$sdfdsdf";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}