const regex = /^[^a\n\r]*(?<!\S)([^\Wa]*a\w*)(?!\S)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[^a\\n\\r]*(?<!\\S)([^\\Wa]*a\\w*)(?!\\S)', 'gm')
const str = `The cat ate the dog
and the mouse
this is a test
a
when will this be matching?
@!#SSDF2#\$@a#\$dsfs\$sdfdsdf`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}