const regex = /(?<=-354).*(\.pdf)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=-354).*(\\.pdf)', 'gm')
const str = `Name1-354-03.pdf
Name23-354-H11.pdf
Name354-354-02.pdf
Name3545-354.pdf"
`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);