$re = '/(?<=-354).*(\.pdf)/m';
$str = 'Name1-354-03.pdf
Name23-354-H11.pdf
Name354-354-02.pdf
Name3545-354.pdf"
';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;