import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^discography\\/type(?:\\/(?:(?:[^\\/]*[.])?(\\d+)\\/?|[^\\/]+\\/?)?)?$";
final String string = "discography/type\n"
+ "discography/type/\n"
+ "discography/type/4\n"
+ "discography/type/albums.4\n"
+ "discography/type/albums/\n"
+ "discography/type/4//\n"
+ "discography/type//\n"
+ "discography/type/singles.4//";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}