re = /^discography\/type(?:\/(?:(?:[^\/]*[.])?(\d+)\/?|[^\/]+\/?)?)?$/m
str = 'discography/type
discography/type/
discography/type/4
discography/type/albums.4
discography/type/albums/
discography/type/4//
discography/type//
discography/type/singles.4//'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end