const regex = new RegExp('\\b[A-Ja-j](?:10|[1-9])\\b', 'gm')
const str = `For example it should match "A10", "A1", "E9"
It should not match "A100", "A30", "P7", "A01"`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}