$re = '/\b[A-Ja-j](?:10|[1-9])\b/m';
$str = 'For example it should match "A10", "A1", "E9"
It should not match "A100", "A30", "P7", "A01"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);