$re = '/^(?<!\+)[a-z0-9\-]+(?<!-)$/m';
$str = 'symfony-4-struktura-frejmvorka----
+++symfony-4-struktura-frejmvorka
+++symfony-4-struktura-frejmvorka----
symfony-4-struktura-frejmvorka';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);