re = /^(?<!\+)[a-z0-9\-]+(?<!-)$/m
str = 'symfony-4-struktura-frejmvorka----
+++symfony-4-struktura-frejmvorka
+++symfony-4-struktura-frejmvorka----
symfony-4-struktura-frejmvorka'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end