#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[^-\+A-Z][a-z0-9\-]+[^-\+A-Z]$"
Local $sString = "symfony-4-struktura-frejmvorka----" & @CRLF & _
"++symfony-4-struktura-frejmvorka" & @CRLF & _
"+symfony-4-struktura-frejmvorka-" & @CRLF & _
"symfony-4-struktura-frejmvorka" & @CRLF & _
"symfony-4-struktura-frejmvorka+" & @CRLF & _
"--symfony-4-struktura-frejmvorka" & @CRLF & _
"symfony-4-struktura-frejmvorkA" & @CRLF & _
"Symfony-4-struktura-frejmvorkA"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")