using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[^-\+A-Z][a-z0-9\-]+[^-\+A-Z]$";
string input = @"symfony-4-struktura-frejmvorka----
++symfony-4-struktura-frejmvorka
+symfony-4-struktura-frejmvorka-
symfony-4-struktura-frejmvorka
symfony-4-struktura-frejmvorka+
--symfony-4-struktura-frejmvorka
symfony-4-struktura-frejmvorkA
Symfony-4-struktura-frejmvorkA";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}