package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b(?:\d[ -]*?){13,16}\b`)
var str = `1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}