$re = '/\b(?:\d[ -]*?){13,16}\b/m';
$str = '1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);