import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=\\d+(?:/\\d+/\\d+)?$)(?:02/?(?:[01]\\d|2\\d)/?(?:19|20)(?:0[048]|[13579][26]|[2468][048])|(?:0[13578]|10|12)/?(?:[0-2]\\d|3[01])/?(?:19|20)\\d{2}|(?:0[469]|11)/?(?:[0-2]\\d|30)/?(?:19|20)\\d{2}|02/?(?:[0-1]\\d|2[0-8])\\?(?:19|20)\\d{2})$";
final String string = "12/31/2000\n"
+ "12312000\n"
+ "12/31 000\n"
+ "12/31-000\n"
+ "1231/2000";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}