const regex = new RegExp('^(?=\\d+(?:/\\d+/\\d+)?$)(?:02/?(?:[01]\\d|2\\d)/?(?:19|20)(?:0[048]|[13579][26]|[2468][048])|(?:0[13578]|10|12)/?(?:[0-2]\\d|3[01])/?(?:19|20)\\d{2}|(?:0[469]|11)/?(?:[0-2]\\d|30)/?(?:19|20)\\d{2}|02/?(?:[0-1]\\d|2[0-8])\\?(?:19|20)\\d{2})$', 'gm')
const str = `12/31/2000
12312000
12/31 000
12/31-000
1231/2000`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}