const regex = new RegExp('^(?=.*\\b(DV|DoVi|Dolby[ .]?Vision)\\b)(?=.*\\b(HDR(10)?(?!\\+))\\b)', 'gmi')
const str = `# DV HDR10
Movie.2015.UHD.BluRay.2160p.TrueHD.Atmos.7.1.HDR.DoVi.HEVC.REMUX-RlsGrp
Movie.2015.UHD.BluRay.2160p.TrueHD.Atmos.7.1.DoVi.HDR.HEVC.REMUX-RlsGrp
Movie.2015.UHD.BluRay.2160p.TrueHD.Atmos.7.1.DoVi.HDR10.HEVC.REMUX-RlsGrp
Movie.2015.UHD.BluRay.2160p.TrueHD.Atmos.7.1.DV.HDR.HEVC.REMUX-RlsGrp
Movie.2015.UHD.BluRay.2160p.TrueHD.Atmos.7.1.HDR.DV.HEVC.REMUX-RlsGrp
Movie.2015.UHD.BluRay.2160p.TrueHD.Atmos.7.1.DV.HDR10.HEVC.REMUX-RlsGrp
Movie.2015.UHD.BluRay.2160p.TrueHD.Atmos.7.1.HDR10.DV.HEVC.REMUX-RlsGrp
Movie (2015) [Remux-2160p][TrueHD Atmos 7.1][DV HDR10][HEVC]-RlsGrp
# DV
Movie.2015.UHD.BluRay.2160p.TrueHD.Atmos.7.1.DV.HEVC.REMUX-RlsGrp
Movie.2015.UHD.BluRay.2160p.TrueHD.Atmos.7.1.DoVi.HEVC.REMUX-RlsGrp
Movie (2015) [Remux-2160p][TrueHD Atmos 7.1][DV][HEVC]-RlsGrp
# this should be picked up as DV and will be DV HDR10 on import
Movie.2015.UHD.BluRay.2160p.TrueHD.Atmos.7.1.DV.HDR10Plus.HEVC.REMUX-RlsGrp
Movie.2015.UHD.BluRay.2160p.TrueHD.Atmos.7.1.DV.HDR10P.HEVC.REMUX-RlsGrp
Movie.2015.UHD.BluRay.2160p.TrueHD.Atmos.7.1.DV.HDR10+.HEVC.REMUX-RlsGrp
# DV HLG
Movie.2015.UHD.BluRay.2160p.TrueHD.Atmos.7.1.DV.HLG.HEVC.REMUX-RlsGrp
Movie (2015) [Remux-2160p][TrueHD Atmos 7.1][DV HLG][HEVC]-RlsGrp
# DV SDR
Movie.2015.UHD.BluRay.2160p.TrueHD.Atmos.7.1.DV.SDR.HEVC.REMUX-RlsGrp
Movie (2015) [Remux-2160p][TrueHD Atmos 7.1][DV SDR][HEVC]-RlsGrp
# HDR10Plus
Movie.2015.UHD.BluRay.2160p.TrueHD.Atmos.7.1.HDR10Plus.HEVC.REMUX-RlsGrp
Movie.2015.UHD.BluRay.2160p.TrueHD.Atmos.7.1.HDR10P.HEVC.REMUX-RlsGrp
Movie.2015.UHD.BluRay.2160p.TrueHD.Atmos.7.1.HDR10+.HEVC.REMUX-RlsGrp
Movie (2015) [Remux-2160p][TrueHD Atmos 7.1][HDR10Plus][HEVC]-RlsGrp
# HDR10
Movie.2015.UHD.BluRay.2160p.TrueHD.Atmos.7.1.HDR10.HEVC.REMUX-RlsGrp
Movie (2015) [Remux-2160p][TrueHD Atmos 7.1][HDR10][HEVC]-RlsGrp
# HDR
Movie.2015.UHD.BluRay.2160p.TrueHD.Atmos.7.1.HDR.HEVC.REMUX-RlsGrp
# HDR (undefined) - This one we might best keep as separate conditions ?
Movie.2015.UHD.BluRay.2160p.TrueHD.Atmos.7.1.HEVC.REMUX-RlsGrp
# PQ
Movie.2015.UHD.BluRay.2160p.TrueHD.Atmos.7.1.PQ.HEVC.REMUX-RlsGrp
Movie (2015) [Remux-2160p][TrueHD Atmos 7.1][PQ][HEVC]-RlsGrp
# HLG/HLG10
Movie.2015.UHD.BluRay.2160p.TrueHD.Atmos.7.1.HLG.HEVC.REMUX-RlsGrp
Movie.2015.UHD.BluRay.2160p.TrueHD.Atmos.7.1.HLG10.HEVC.REMUX-RlsGrp
Movie (2015) [Remux-2160p][TrueHD Atmos 7.1][HLG10][HEVC]-RlsGrp
# DON'T MATCH
adventure
hdruin
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}