import Foundation
let pattern = #"^(?=.*\b(DV|DoVi|Dolby[ .]?Vision)\b)(?=.*\b(HDR(10)?(?!\+))\b)"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = ##"""
# DV HDR10
Movie.2015.UHD.BluRay.2160p.TrueHD.Atmos.7.1.HDR.DoVi.HEVC.REMUX-RlsGrp
Movie.2015.UHD.BluRay.2160p.TrueHD.Atmos.7.1.DoVi.HDR.HEVC.REMUX-RlsGrp
Movie.2015.UHD.BluRay.2160p.TrueHD.Atmos.7.1.DoVi.HDR10.HEVC.REMUX-RlsGrp
Movie.2015.UHD.BluRay.2160p.TrueHD.Atmos.7.1.DV.HDR.HEVC.REMUX-RlsGrp
Movie.2015.UHD.BluRay.2160p.TrueHD.Atmos.7.1.HDR.DV.HEVC.REMUX-RlsGrp
Movie.2015.UHD.BluRay.2160p.TrueHD.Atmos.7.1.DV.HDR10.HEVC.REMUX-RlsGrp
Movie.2015.UHD.BluRay.2160p.TrueHD.Atmos.7.1.HDR10.DV.HEVC.REMUX-RlsGrp
Movie (2015) [Remux-2160p][TrueHD Atmos 7.1][DV HDR10][HEVC]-RlsGrp
# DV
Movie.2015.UHD.BluRay.2160p.TrueHD.Atmos.7.1.DV.HEVC.REMUX-RlsGrp
Movie.2015.UHD.BluRay.2160p.TrueHD.Atmos.7.1.DoVi.HEVC.REMUX-RlsGrp
Movie (2015) [Remux-2160p][TrueHD Atmos 7.1][DV][HEVC]-RlsGrp
# this should be picked up as DV and will be DV HDR10 on import
Movie.2015.UHD.BluRay.2160p.TrueHD.Atmos.7.1.DV.HDR10Plus.HEVC.REMUX-RlsGrp
Movie.2015.UHD.BluRay.2160p.TrueHD.Atmos.7.1.DV.HDR10P.HEVC.REMUX-RlsGrp
Movie.2015.UHD.BluRay.2160p.TrueHD.Atmos.7.1.DV.HDR10+.HEVC.REMUX-RlsGrp
# DV HLG
Movie.2015.UHD.BluRay.2160p.TrueHD.Atmos.7.1.DV.HLG.HEVC.REMUX-RlsGrp
Movie (2015) [Remux-2160p][TrueHD Atmos 7.1][DV HLG][HEVC]-RlsGrp
# DV SDR
Movie.2015.UHD.BluRay.2160p.TrueHD.Atmos.7.1.DV.SDR.HEVC.REMUX-RlsGrp
Movie (2015) [Remux-2160p][TrueHD Atmos 7.1][DV SDR][HEVC]-RlsGrp
# HDR10Plus
Movie.2015.UHD.BluRay.2160p.TrueHD.Atmos.7.1.HDR10Plus.HEVC.REMUX-RlsGrp
Movie.2015.UHD.BluRay.2160p.TrueHD.Atmos.7.1.HDR10P.HEVC.REMUX-RlsGrp
Movie.2015.UHD.BluRay.2160p.TrueHD.Atmos.7.1.HDR10+.HEVC.REMUX-RlsGrp
Movie (2015) [Remux-2160p][TrueHD Atmos 7.1][HDR10Plus][HEVC]-RlsGrp
# HDR10
Movie.2015.UHD.BluRay.2160p.TrueHD.Atmos.7.1.HDR10.HEVC.REMUX-RlsGrp
Movie (2015) [Remux-2160p][TrueHD Atmos 7.1][HDR10][HEVC]-RlsGrp
# HDR
Movie.2015.UHD.BluRay.2160p.TrueHD.Atmos.7.1.HDR.HEVC.REMUX-RlsGrp
# HDR (undefined) - This one we might best keep as separate conditions ?
Movie.2015.UHD.BluRay.2160p.TrueHD.Atmos.7.1.HEVC.REMUX-RlsGrp
# PQ
Movie.2015.UHD.BluRay.2160p.TrueHD.Atmos.7.1.PQ.HEVC.REMUX-RlsGrp
Movie (2015) [Remux-2160p][TrueHD Atmos 7.1][PQ][HEVC]-RlsGrp
# HLG/HLG10
Movie.2015.UHD.BluRay.2160p.TrueHD.Atmos.7.1.HLG.HEVC.REMUX-RlsGrp
Movie.2015.UHD.BluRay.2160p.TrueHD.Atmos.7.1.HLG10.HEVC.REMUX-RlsGrp
Movie (2015) [Remux-2160p][TrueHD Atmos 7.1][HLG10][HEVC]-RlsGrp
# DON'T MATCH
adventure
hdruin
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)