import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "SELECT\\s+((?:.(?!SELECT))*)\\s+FROM INSERTED";
final String string = "SELECT 1 FROM INSERTED i\n\n"
+ "SELECT 'Hello, world!' FROM INSERTED i\n\n"
+ "SET @foo = (SELECT @@userid)\n\n"
+ "SELECT * FROM INSERTED i\n\n"
+ "SELECT\n"
+ " One,\n"
+ " Two,\n"
+ " Three, Four,\n"
+ " Five,\n"
+ " Six, Seven, Eight,\n"
+ " Nine, Ten\n"
+ "FROM INSERTED i\n\n"
+ "SET @bar = (SELECT TOP(1) PatronID FROM INSERTED i)";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL | Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}