import Foundation
let pattern = #"SELECT\s+((?:.(?!SELECT))*)\s+FROM INSERTED"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive, .dotMatchesLineSeparators])
let testString = #"""
SELECT 1 FROM INSERTED i
SELECT 'Hello, world!' FROM INSERTED i
SET @foo = (SELECT @@userid)
SELECT * FROM INSERTED i
SELECT
One,
Two,
Three, Four,
Five,
Six, Seven, Eight,
Nine, Ten
FROM INSERTED i
SET @bar = (SELECT TOP(1) PatronID FROM INSERTED i)
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)