const regex = /\b(?!0x)[0-9A-Fx]+\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(?!0x)[0-9A-Fx]+\\b', 'gm')
const str = `0x12 0x34 0x56 0x7 0x88 0x98 0x76 0x5 1x23`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}