$re = '/\b(?!0x)[0-9A-Fx]+\b/m';
$str = '0x12 0x34 0x56 0x7 0x88 0x98 0x76 0x5 1x23';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);