// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\w{3}\s\d{2}\s\d{2}:\d{2}:\d{2}\s\w{6}\.\w{5}\s\w{5}:)\s(\w*)\s\w*\s\w*\s").unwrap();
let string = "Jan 31 13:08:10 ubuntu.local ticky: INFO Closed ticket [#8685] (rr.robinson)
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}