package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[0-9]+(\.[0-9]{1,2})?$`)
var str = `1
1.5
1.25
0.75
2.50`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}