$re = '/^[0-9]+(\.[0-9]{1,2})?$/m';
$str = '1
1.5
1.25
0.75
2.50';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);