$re = '/^(?:WT|PBMC)\-\d{5,6}/m';
$str = 'These should match:
PBMC-12345: listless, off feed
WT-234293 is unremarkable
These should not match:
the mouse PBMC-12345
subject WT-234293
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);