// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:WT|PBMC)\-\d{5,6}").unwrap();
let string = "These should match:
PBMC-12345: listless, off feed
WT-234293 is unremarkable
These should not match:
the mouse PBMC-12345
subject WT-234293
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}