$re = '/^(?=.{1,8}$)[A-Z]+[0-9]*$/m';
$str = 'A123948182312931392391239129
AA123124
A1213b';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);