re = /^(?=.{1,8}$)[A-Z]+[0-9]*$/m
str = 'A123948182312931392391239129
AA123124
A1213b'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end